:::: MENU ::::

Script otomatis Mematikan NAT jika server Proxy Shutdown

Setelah berhasil melakukan implementasi pada server lokal yang me-redirect ke server proxy. Maka semua akses keluar dari jaringan lokal akan dialihkan ke server proxy, namun terjadi masalah jika terjadi listrik padam dan UPS tidak bisa bertahan lama untuk tetap menghidupkan server proxy. Yakni, internet akan mati karena akses ke luar jaringan dialihkan ke server proxy, yang dalam keadaan mati. Berarti internet putus dan komplain akan berdatangan. :)

Script ini digunakan untuk mengecek apakah server proxy dalam keadaan hidup atau mati.

/tool netwatch
add disabled=no down-script=”/ip firewall nat disable [find comment=Transparent-Proxy]”\ host=192.168.70.2 interval=2s timeout=1s up-script=\
“/ip firewall nat enable [find comment=Transparent-Proxy]”

Continue Reading


Script untuk me-redirect Internet ke eksternal proxy

Kembali membuat catatan perjalanan dalam administrasi jaringan disekolah. Setelah berhasil melakukan instalasi ubuntu server sebagai server ekternal. Sebelumnya masih menggunakan mikrotik PC yang bisa digabungkan dengan proxy internal, namun sekarang menggunakan RouterBoard, maka proxy harus dialihkan ke proxy eksternal.

Pastikan bahwa komputer sudah siap untuk digunakan termasuk sudah di install squid sebagai engine proxy. Berikut ini adalah script yang digunakan untuk melakukan pengalihan atau redirect ke proxy eksternal.

/ip firewall nat
add action=dst-nat chain=dstnat comment=Transparent-Proxy disabled=no dst-address-\ list=!local dst-port=80 in-interface=ether2-elmadrasi protocol=tcp\ to-addresses=192.168.70.2 to-ports=3128

Continue Reading



Redirect URL menggunakan Squid Proxy Server

Diawali dengan pertanyaan teman saya, yakni ketika kita mengetikan alamat/domain pada browser yang mana domain/alamat tersebut belum didaftarkan di internet, maka secara otomatis akan diredirect ke suatu situs yang tidak baik bagi orang-orang umum untuk melihatnya. Contoh ketika kamu mengetikan alamat http://anelagigalunih.com, maka akan diredirect ke alamat lain. Pertamanya saya juga heran mengapa terjadi seperti itu, akhirnya menemukan penjelasan mengenai kenapa hal itu terjadi, anda bisa membaca tulisan tersebut di sini DNS Public Google/NAWALA di Hack atau sengaja ??.

Continue Reading


Melakukan bypass limit pada caching proxy eksternal di mikrotik

Setelah kami selesai melakukan perbaikan pada proxy yang di install di computer proxy berbasis linux ubuntu server. Caching proxy serpertinya sudah berjalan normal, dapat dilihat dari paket data yang ada pada interface mikrotik, paket-paket dilewatkan ke computer proxy sebelum dilanjutkan ke computer client melalui dua buah jaringan dengan menggunakan hotspot.

Caching proxy nampaknya sudah memakan tempat yang cukup besar, ini artinya proxy sudah banyak menyimpan data-data dari internet dan sebagian sudah melakukan hit dari proxy.
Dari sini timbul permasalahan dimana dua jaringan yang di ada didalam hotspot menggunakan limit sesuai dengan user profil di hotspot tersebut. Untuk itu kami perlu melakukan setingan tambahan untuk mem-bypass limit yang ada di hotspot tersebut.

Continue Reading