How to change hotspot login mikrotik router automatically

Introduction

This article complete my video tutorial about how to change hotspot login page automatically in mikrotik router.

Script

/ip hotspot profile set html-directory=manic numbers=1

Number=1 is number of your hotspot profile number, make sure you match with your configuration.

Html-directory=manic is name of your directory that contain your login page, when internet access provided.

/ip hotspot profile set html-directory=maintenis numbers=1

Number=1 is number of your hotspot profile number, make sure you match with your configuration.

Html-directory=maintenis is name of your directory that contain information that internet is down.

Complete script in TOOL -> NETWATCH.

/tool netwatch
add comment="Tes Internet" disabled=no host=8.8.8.8 timeout=30s interval=50s\
    down-script=\
    "/ip hotspot profile set html-directory=maintenis numbers=1" 
    up-script=\
    "ip hotspot profile set html-directory=manic numbers=1"

Video

Leave a Reply

Silahkan isi perhitungan di bawah ini : *